summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2001-08-30 05:09:11 +0000
committerTor Lillqvist <tml@src.gnome.org>2001-08-30 05:09:11 +0000
commit74b4d8c22e6b63661430395f40b978684009c29b (patch)
tree779d758cbd7f2c7b21185c425402536bc111c051 /Makefile.am
parent66529cef67ae7bf10ddf81ca7a243c4576a7fa9e (diff)
After being away for about five months, I'm back working on this... For
2001-08-30 Tor Lillqvist <tml@iki.fi> After being away for about five months, I'm back working on this... For now, still using same build setup for Win32. Probably will change to not including version numbers in the import library names, though. (But the DLL names would still include them, possibly even also the micro version number.) That would be more Unix-like. Also, will have to check out newest mingw tool versions to see if the build-dll script now can be retired. * makefile.mingw * makefile.msc: New files, no need to generate from .in as they don't contain references to automake variables. * makefile.mingw.in * makefile.msc.in: Removed. * glib.rc.in: Remove * glib/glib.rc.in: Moved here. * Makefile.am * glib/Makefile.am: Corresponding changes. * glib/glib.def: Fix typo, add new entries. * glib/gspawn-win32-helper.c: More debugging. Doesn't work currently (or then it never has on Win2k, which I now use?) * glib/gstrfuncs.c * glib/gstrfuncs.h: Mark g_ascii_table for export/import on Win32. * */makefile.mingw.in: Reflect new location of glib library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 43764b580..6b21f7c48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,12 +15,11 @@ EXTRA_DIST = \
sanity_check \
README.win32 \
TODO.xml \
- makefile.msc.in \
- makefile.mingw.in \
+ makefile.msc \
+ makefile.mingw \
glibconfig.h.win32.in \
config.h.win32.in \
build-dll \
- glib.rc.in \
glib-2.0.pc.in \
gobject-2.0.pc.in \
gmodule-2.0.pc.in \
@@ -32,8 +31,6 @@ EXTRA_DIST = \
# These may be in the builddir too
BUILT_EXTRA_DIST = \
- makefile.msc \
- makefile.mingw \
glibconfig.h.win32 \
config.h.win32 \
glib.rc \
@@ -70,12 +67,6 @@ glibconfig.h.win32: $(top_builddir)/config.status $(top_srcdir)/glibconfig.h.win
config.h.win32: $(top_builddir)/config.status $(top_srcdir)/config.h.win32.in
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-makefile.msc: $(top_builddir)/config.status $(top_srcdir)/makefile.msc.in
- cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
-makefile.mingw: $(top_builddir)/config.status $(top_srcdir)/makefile.mingw.in
- cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
glib.rc: $(top_builddir)/config.status $(top_srcdir)/glib.rc.in
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status