summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2010-06-15 22:01:02 -0400
committerMatthias Clasen <mclasen@redhat.com>2010-06-15 22:01:02 -0400
commit1b8ee5196eb8ed684b0ee0d2f0d26e6bd82656af (patch)
tree3e328d1cd43b66d9c57d1ff317d2d3ce1a81c23c /Makefile.am
parent062148ae9a4176a28c055a6e3505f4e5c9ff6313 (diff)
Sprinkle some $(AM_V_GEN) around to make the build more silent.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ace9c9a88..5748ca33c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,15 +82,14 @@ CONFIGURE_DEPENDENCIES = acglib.m4
BUILT_SOURCES = stamp-gc-h #note: not glibconfig.h
glibconfig.h: stamp-gc-h
- @if test -f glibconfig.h; then :; \
+ $(AM_V_GEN) if test -f glibconfig.h; then :; \
else rm -f stamp-gc-h; $(MAKE) stamp-gc-h; fi
stamp-gc-h: config.status
cd $(top_builddir) && $(SHELL) ./config.status glibconfig.h
echo timestamp > stamp-gc-h
ChangeLog:
- @echo Creating $@
- @if test -d "$(srcdir)/.git"; then \
+ $(AM_V_GEN) test -d "$(srcdir)/.git"; then \
(GIT_DIR=$(top_srcdir)/.git ./missing --run git log GLIB_2_20_0^^.. --stat) | fmt --split-only > $@.tmp \
&& mv -f $@.tmp $@ \
|| ($(RM) $@.tmp; \