summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2016-01-21 20:06:09 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2016-01-21 20:06:09 +0000
commit88e9da1ddec51a99246d5128a6202dd9205af34c (patch)
treee63a7c53d07ee4803bca6ee61c9c32c77ab9fa37 /Makefile.am
parentd7677ab1bcabe60e84215eb17b51b644737bfcb0 (diff)
Add a setup.py which wraps Autotools in something virtualenv-friendly
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 53c38ab..e23b508 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,7 @@ EXTRA_DIST = \
m4/am-check-pymod.m4 \
m4/am-check-python-headers.m4 \
m4/dbus-py-add-rst2htmlflag.m4 \
+ setup.py \
test/TestSuitePythonService.service.in \
test/tmp-session-bus.conf.in \
tools/check-coding-style.mk \
@@ -347,6 +348,7 @@ $(patsubst %,%.test,$(test_programs)): %.test: Makefile
# === Documentation ===
dist-hook:
+ echo $(VERSION) > $(distdir)/.version
chmod u+w $(distdir)/ChangeLog
if test -d $(top_srcdir)/.git; then \
if GIT_DIR=$(top_srcdir)/.git git log --stat > $(distdir)/ChangeLog; then \
@@ -355,6 +357,13 @@ dist-hook:
GIT_DIR=$(top_srcdir)/.git git log > $(distdir)/ChangeLog; \
fi; \
fi
+ touch $(distdir)/MANIFEST
+ touch $(distdir)/MANIFEST.in
+ ( cd $(distdir) && find -type d -o -print ) | \
+ LC_ALL=C sort | \
+ $(SED) -e 's|^\./||' \
+ > $(distdir)/MANIFEST
+ sed -e 's/.*/include &/' < $(distdir)/MANIFEST > $(distdir)/MANIFEST.in
TXT_RSTDOCS = \
doc/tutorial.txt \