summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-02-22 13:18:18 +0000
committerSimon McVittie <smcv@debian.org>2016-02-22 13:18:18 +0000
commit84b7bdafc1deecd9451ba52c30e5dc63a7ebb056 (patch)
treedc0bbb0e0391f95ef5111878bd2ebfdfa045a135 /Makefile.am
parenta7c0dc02695addec1a2ed4c2277878c514883c9d (diff)
Don't install crosstest.py executable
It's meant to be imported, not executed. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 309cd5a..3a821fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -244,10 +244,13 @@ dist_test_py = \
test/test-unusable-main-loop.py \
$(NULL)
+dist_test_extra_python = \
+ test/crosstest.py \
+ $(NULL)
+
dist_test_extra_scripts = \
test/cross-test-client.py \
test/cross-test-server.py \
- test/crosstest.py \
test/test-service.py \
test/wait-for-name.py \
test/with-session-bus.sh \
@@ -308,6 +311,9 @@ nobase_dist_installed_test_SCRIPTS = \
$(dist_test_sh) \
$(dist_test_extra_scripts) \
$(NULL)
+nobase_dist_installed_test_PYTHON = \
+ $(dist_test_extra_python) \
+ $(NULL)
installed_test_test_DATA = $(installed_test_test_data)
installed_test_meta_DATA = $(installed_test_metadata)
else