summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-05-31 14:33:18 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-06-01 17:16:45 +0100
commit98d7cb8c869b53686a742fb48d1f189c74ff1484 (patch)
tree28131fd4cd72e316e69ef9e2f3e57100a1665b5d /configure.ac
parentb00d53dd647cf456ddb67c1dfdf44a8d56be90b4 (diff)
Simplify the check for dbus-1
As in commit 0f782b4, omitting the action-if-found and action-if-not-found results in much better error messages if this mandatory dependency isn't found. Nothing checks HAVE_DBUS (as they shouldn't - it's mandatory!), so there's no point in keeping that either. Reviewed-by: Will Thompson <will.thompson@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=37789
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7919b2a..8ed8ca6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -331,15 +331,9 @@ XML_CFLAGS=
#### Set up final flags
-PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.2.16, have_dbus=yes, have_dbus=no)
-
-if test x$have_dbus = xno ; then
- AC_MSG_ERROR([DBus development libraries not found])
-fi
-AM_CONDITIONAL(HAVE_DBUS, test x$have_dbus = xyes)
-
-AC_SUBST(DBUS_CFLAGS)
-AC_SUBST(DBUS_LIBS)
+PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.2.16])
+AC_SUBST([DBUS_CFLAGS])
+AC_SUBST([DBUS_LIBS])
DBUS_INCLUDEDIR=`pkg-config dbus-1 --variable=includedir`
AC_SUBST(DBUS_INCLUDEDIR)