summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2009-07-16 13:51:57 -0400
committerColin Walters <walters@verbum.org>2009-07-16 13:51:57 -0400
commit65e03ccf0f2417a83fd187035b80d680e376fd32 (patch)
tree11f7a1aa8440c8cc558ec0af48283eb10f109727 /Makefile.am
parentf5edb761202d3aff8f8bd0bc68dd57d3d32d2bd1 (diff)
Test for git-log in Makefile.am should just be for git now
The combined tools are no longer in $PATH for modern git.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index bb49d8e..08bf5b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,19 +22,19 @@ MAINTAINERCLEANFILES = ChangeLog
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc --enable-checks --enable-tests
EXTRA_DIST += ChangeLog
-ChangeLog: $(srcdir)/ChangeLog
+ChangeLog:
$(srcdir)/ChangeLog: FORCE
@if test -d "$(srcdir)/.git"; then \
(cd "$(srcdir)" && \
- ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
+ ./missing --run git log --stat) | fmt --split-only > $@.tmp \
&& mv -f $@.tmp $@ \
|| ($(RM) $@.tmp; \
echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
(test -f $@ || echo git-log is required to generate this file >> $@)); \
else \
test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
+ (echo A git checkout and git log are required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log are required to generate this file >> $@); \
fi
all-local: Doxyfile