summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-05-21 14:26:01 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-05-21 14:31:56 +0100
commitf6b42d1f56c9732a2ae9533b17ab95b5e8979828 (patch)
tree98d800053aec4ae9992fee7dd70b8687d03f305e /meson.build
parentfe5111e71df96bbb65db4ff2f1654e5636006f7b (diff)
meson: don't need config.h.meson any more
Meson does the largefile support automatically nowadays, and can generate a config.h from configuration_data() without a template as input.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 83c34cc71..fe8cee5ee 100644
--- a/meson.build
+++ b/meson.build
@@ -49,10 +49,6 @@ elif cc.has_argument('-Wl,-Bsymbolic-functions')
endif
cdata = configuration_data()
-cdata.set('GST_VERSION_MAJOR', gst_version_major)
-cdata.set('GST_VERSION_MINOR', gst_version_minor)
-cdata.set('GST_VERSION_MICRO', gst_version_micro)
-cdata.set('GST_VERSION_NANO', gst_version_nano)
cdata.set('GST_API_VERSION', '"@0@"'.format(apiversion))
cdata.set('GST_DATADIR', '"@0@/@1@"'.format(prefix, get_option('datadir')))
cdata.set('LOCALEDIR', '"@0@/@1@"'.format(prefix, get_option('localedir')))
@@ -430,9 +426,7 @@ subdir('tests')
subdir('po')
subdir('data')
-configure_file(input : 'config.h.meson',
- output : 'config.h',
- configuration : cdata)
+configure_file(output : 'config.h', configuration : cdata)
if build_machine.system() == 'windows'
message('Disabling gtk-doc while building on Windows')