summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-07-07 12:06:44 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-07-07 12:07:09 +0100
commitf28435b0d4d40953086b638dfe67724fedc772c3 (patch)
tree560ae88b0d281ad1ff594ab3fedaabe4aeee763c /meson.build
parentd93ebba58b9c19e31f9a0e4061b243bd9ab489b6 (diff)
meson: find python3 via python3 module
And rename python3 variable in meson build files for clarity. https://bugzilla.gnome.org/show_bug.cgi?id=783198
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 6fa2df08a..8f4dc2c72 100644
--- a/meson.build
+++ b/meson.build
@@ -385,11 +385,7 @@ if libtype == 'static'
endif
# Used in gst/parse/meson.build and below
-py3 = find_program('python3', required : false)
-if not py3.found()
- # Maybe 'python' is Python 3
- py3 = find_program('python')
-endif
+python3 = import('python3').find_python()
bashcomp_dep = dependency('bash-completion', version : '>= 2.0', required : false)
@@ -449,6 +445,6 @@ else
endif
endif
-run_command(py3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')
+run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')
install_data('gst-element-check-1.0.m4', install_dir : join_paths(get_option('datadir'), 'aclocal'))