summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2017-04-09 12:09:33 +0300
committerSebastian Dröge <sebastian@centricular.com>2017-04-09 12:09:33 +0300
commitdc71c4a47798c9e37061e1e295ace03c37cbd428 (patch)
tree04aa236d864e5279695ec554fd7e7be27db6c66b /meson.build
parentc7cc48b42e53489dbf94763bf721feb9a27080a6 (diff)
meson: Add check for glib-mkenums
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b53686991..73568d3f0 100644
--- a/meson.build
+++ b/meson.build
@@ -363,6 +363,9 @@ gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' +
'gst_init(NULL,NULL);' ]
vs_module_defs_dir = meson.current_source_dir() + '/win32/common/'
+# Used by the *_mkenum.py helper scripts
+glib_mkenums = find_program('glib-mkenums')
+
gst_c_args = ['-DHAVE_CONFIG_H']
if libtype == 'static'
gst_c_args += ['-DGST_STATIC_COMPILATION']