summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@gnome.org>2016-12-09 17:55:39 -0300
committerThibault Saunier <tsaunier@gnome.org>2016-12-09 17:57:10 -0300
commitbd5d43e8f9f86430d241b7cb534638faeca5d9d9 (patch)
treeb87ee0cb8861fcc1b65399d682174c8163503173 /meson.build
parentf8df150e2990756247e462ba75ea88328d705ead (diff)
meson: Support building with Gst debug disabled
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 19c363969..034c7407c 100644
--- a/meson.build
+++ b/meson.build
@@ -316,6 +316,12 @@ if cc.has_header('execinfo.h')
endif
endif
+disable_gst_debug = get_option('disable_gst_debug')
+if get_option('disable_gst_debug')
+ cdata.set('GST_DISABLE_GST_DEBUG_DEFINE', '#define GST_DISABLE_GST_DEBUG 1')
+ add_project_arguments(['-Wno-unused'], language: 'c')
+endif
+
configure_file(input : 'config.h.meson',
output : 'config.h',
configuration : cdata)