summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2016-10-20 15:38:46 -0300
committerTim-Philipp Müller <tim@centricular.com>2016-11-14 19:21:13 +0000
commitae608845ca83ab02c5a386285375c36778874151 (patch)
treec94bf93eaa8e4e5e2b2df0b41dff428a5c19ce1a /meson.build
parent5a72c23a54ffc8d61ab94969844e73b3b1a293ec (diff)
meson: require meson 0.36 and use new `pic` arg on static libs
Removes a meson warning and some special casing we had.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 572227b0c..0df520f6d 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gstreamer', 'c', 'cpp',
version : '1.11.0.1',
- meson_version : '>= 0.35.0',
+ meson_version : '>= 0.36.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -29,14 +29,6 @@ helpers_install_dir = libexecdir + '/gstreamer-1.0/'
cc = meson.get_compiler('c')
-# FIXME: Meson should have a way for portably adding -fPIC when needed for use
-# with static libraries that are linked into shared libraries. Or, it should
-# add it by default with an option to turn it off if needed.
-pic_args = ['-fPIC']
-if host_machine.system() == 'windows'
- pic_args = []
-endif
-
# Ignore several spurious warnings for things gstreamer does very commonly
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once