summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2016-12-21 09:33:39 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2016-12-21 23:51:36 +0530
commit77d2774f1bcb337047911560c6f8fb0be52c1a0c (patch)
tree4c9417d6558d4bc753b775c9564cc16d80b24483 /meson.build
parent97f39cae6367390a7d3a216f851ab5946b61b329 (diff)
build: Remove unused functions
fgetpos, fsetpos, mmap, posix_memalign. None of these are used anywhere in the codebase.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index d8fae79e4..9571caaa4 100644
--- a/meson.build
+++ b/meson.build
@@ -147,8 +147,6 @@ check_functions = [
'getrusage',
'fseeko',
'ftello',
- 'fsetpos',
- 'fgetpos',
'poll',
'pselect',
'getpagesize',
@@ -167,17 +165,12 @@ foreach f : check_functions
endif
endforeach
-cdata.set('HAVE_MMAP', 1)
if cc.has_function('localtime_r', prefix : '#include<time.h>')
cdata.set('HAVE_LOCALTIME_R', 1)
# Needed by libcheck
cdata.set('HAVE_DECL_LOCALTIME_R', 1)
endif
-if cc.has_function('posix_memalign', prefix : '#include<stdlib.h>')
- cdata.set('HAVE_POSIX_MEMALIGN', 1)
-endif
-
# We only want to use the __declspec(dllexport/import) dance in GST_EXPORT when
# building with MSVC
if cc.get_id() == 'msvc'