summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-05-13 18:30:27 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-05-13 18:30:27 +0100
commit4341bd0ba38edf049344b858ce4d6069fa4c1c00 (patch)
tree7db6aaa84f5104e3980df74a0bd9ea9282aff17c /meson.build
parent3325ebb616d98da4433041b832c5ca3e20aa44ff (diff)
meson: add options to set package name and origin
https://bugzilla.gnome.org/show_bug.cgi?id=782172
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 13 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8ad0ee0b0..884b36ea2 100644
--- a/meson.build
+++ b/meson.build
@@ -60,8 +60,6 @@ cdata.set('LIBDIR', '"@0@/@1@"'.format(prefix, get_option('libdir')))
cdata.set('GST_API_VERSION', '"1.0"')
cdata.set('GETTEXT_PACKAGE', '"gstreamer-1.0"')
cdata.set('GST_LICENSE', '"LGPL"')
-cdata.set('GST_PACKAGE_ORIGIN', '"Unknown package origin"')
-cdata.set('GST_PACKAGE_NAME', '"GStreamer source release"')
cdata.set('PACKAGE', '"gstreamer"')
cdata.set('PACKAGE_NAME', '"GStreamer"')
cdata.set('PACKAGE_STRING', '"GStreamer @0@"'.format(gst_version))
@@ -83,6 +81,19 @@ else
cdata.set('GST_LEVEL_DEFAULT', 'GST_LEVEL_NONE')
endif
+# GStreamer package name and origin url
+gst_package_name = get_option('with-package-name')
+if gst_package_name == ''
+ if gst_version_nano == 0
+ cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer source release')
+ elif gst_version_nano == 1
+ cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer git')
+ else
+ cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer prerelease')
+ endif
+endif
+cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
+
# These are only needed/used by the ABI tests
host_defines = [
[ 'x86', 'HAVE_CPU_I386' ],