summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-08-13 09:55:46 +0100
committerTim-Philipp Müller <tim@centricular.com>2016-08-13 10:10:30 +0100
commite2cd6ffafc11e8b1eb2d5ceb44766283c15884ff (patch)
treea326ccac4c879fcc4543c490a4e58c320fc7d0d0 /configure.ac
parent5154dcfbdc582e7491a14fbfa98cc79c222a0a81 (diff)
Remove old alloc tracing code now that we have a GstTracer-based replacement
It's been internal API only in 1.x.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index bdd794648..e116a739c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,10 +101,6 @@ if test "x$GST_DISABLE_OPTION_PARSING" = xyes; then
AC_DEFINE(GST_DISABLE_OPTION_PARSING, 1,
[Define if option parsing is disabled])
fi
-AG_GST_CHECK_SUBSYSTEM_DISABLE(TRACE,[historic tracing subsystem])
-AM_CONDITIONAL(GST_DISABLE_TRACE, test "x$GST_DISABLE_TRACE" = "xyes")
-AG_GST_CHECK_SUBSYSTEM_DISABLE(ALLOC_TRACE,[allocation tracing])
-AM_CONDITIONAL(GST_DISABLE_ALLOC_TRACE, test "x$GST_DISABLE_ALLOC_TRACE" = "xyes")
AG_GST_CHECK_SUBSYSTEM_DISABLE(REGISTRY,[plugin registry])
AM_CONDITIONAL(GST_DISABLE_REGISTRY, test "x$GST_DISABLE_REGISTRY" = "xyes")
dnl define a substitution to use in docs/gst/gstreamer.types
@@ -1109,8 +1105,6 @@ if test "x${GST_DISABLE_GST_DEBUG}" = "xno"; then enable_gst_debug="yes"; fi
if test "x${GST_DISABLE_GST_TRACER_HOOKS}" = "xno"; then enable_gst_tracer_hooks="yes"; fi
if test "x${GST_DISABLE_PARSE}" = "xno"; then enable_parse="yes"; fi
if test "x${GST_DISABLE_OPTION_PARSING}" = "xno"; then enable_option_parsing="yes"; fi
-if test "x${GST_DISABLE_TRACE}" = "xno"; then enable_trace="yes"; fi
-if test "x${GST_DISABLE_ALLOC_TRACE}" = "xno"; then enable_alloc_trace="yes"; fi
if test "x${GST_DISABLE_PLUGIN}" = "xno"; then enable_plugin="yes"; fi
if test "x${GST_DISABLE_REGISTRY}" = "xno"; then enable_registry="yes"; fi
@@ -1131,8 +1125,6 @@ Configuration
Tracing subsystem hooks : ${enable_gst_tracer_hooks}
Command-line parser : ${enable_parse}
Option parsing in gst_init : ${enable_option_parsing}
- Historic tracing subsystem : ${enable_trace}
- Allocation tracing : ${enable_alloc_trace}
Plugin registry : ${enable_registry}
Plugin support : ${enable_plugin}
Static plugins : ${enable_static_plugins}