summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-07-14 16:12:25 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-07-14 16:13:12 +0100
commitd12329118377f99e7e3d4a87fd97c28c79b739b2 (patch)
tree50a0316bb631ed8a1a6d117ccb61ada0bb0de089 /configure.ac
parent5bd4603ed3923e8fa8e81ed0230a0fa219b191b2 (diff)
win32: find plugin scanner in libexecdir subdir as configured
https://bugzilla.gnome.org/show_bug.cgi?id=679115
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d8ce48771..c0e6b095d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -998,6 +998,23 @@ AC_DEFINE_UNQUOTED(GST_PLUGIN_SCANNER_INSTALLED,
"$GST_PLUGIN_SCANNER_INSTALLED", [location of the installed gst-plugin-scanner])
AC_SUBST(GST_PLUGIN_SCANNER_INSTALLED)
+case "${libexecdir}" in
+ *libexec)
+ GST_PLUGIN_SCANNER_SUBDIR="libexec";;
+ *lib)
+ GST_PLUGIN_SCANNER_SUBDIR="lib";;
+ *)
+ GST_PLUGIN_SCANNER_SUBDIR=`basename ${libexecdir}`;
+ if test -z "$GST_PLUGIN_SCANNER_SUBDIR"; then
+ AC_MSG_WARN([Couldn't determined libexecdir suffix, using "lib"])
+ GST_PLUGIN_SCANNER_SUBDIR="lib";
+ fi
+ ;;
+esac
+AC_DEFINE_UNQUOTED(GST_PLUGIN_SCANNER_SUBDIR,
+ "$GST_PLUGIN_SCANNER_SUBDIR", [libexecdir path component, used to find plugin-scanner on relocatable builds on windows])
+
+
dnl completion helper locations
AS_AC_EXPAND(GST_COMPLETION_HELPER_INSTALLED,${libexecdir}/gstreamer-$GST_API_VERSION/gst-completion-helper)
AC_DEFINE_UNQUOTED(GST_COMPLETION_HELPER_INSTALLED,