summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2017-04-04 13:42:50 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-04-04 14:46:48 -0400
commitbae1fe254a0f730a82cd14dfd3deab06c753a8c7 (patch)
treea507fa152f6d9ec3380b8049042786877326bfd4 /configure.ac
parentc3613658909df193e42a71cf6b5f3fcb6d51d2e0 (diff)
completion: Place the completion helper in libexec
This patch reorganize the bash completion scripts in order to install the binary helper (gst-completion-helper) in libexec path rather then share folder. Most Linux hierarchy compliance requires that no binary executable are placed in share. We also cleanup the unused .pc entries and remove copy pasted parts of the script. Note that other project including the common helper, should now use $_GST_HELPER to read the binary executable gst-completion-helper. This helper is not longer version, as it is placed in a versionned subfolder (libexec/gstreamer.10) just like the other helpers (scanner and ptp).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 34a797916..47401f954 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,11 +153,14 @@ then
fi
PKG_CHECK_MODULES([BASH_COMPLETION], [bash-completion >= 2.0],
- [BASH_COMPLETION_DIR="`eval pkg-config $extra_args --variable=completionsdir bash-completion`"],
- [BASH_COMPLETION_DIR="$datadir/bash-completion/completions"])
- PKG_CHECK_MODULES([BASH_COMPLETION], [bash-completion >= 2.0],
- [BASH_HELPERS_DIR="`eval pkg-config $extra_args --variable=helpersdir bash-completion`"],
- [BASH_HELPERS_DIR="$datadir/bash-completion/helpers"])
+ [
+ BASH_COMPLETION_DIR="`eval pkg-config $extra_args --variable=completionsdir bash-completion`"
+ BASH_HELPERS_DIR="`eval pkg-config $extra_args --variable=helpersdir bash-completion`"
+ ],
+ [
+ BASH_COMPLETION_DIR="$datadir/bash-completion/completions"
+ BASH_HELPERS_DIR="$datadir/bash-completion/helpers"
+ ])
else
BASH_COMPLETION_DIR="$with_bash_completion_dir/completions"
BASH_HELPERS_DIR="$with_bash_completion_dir/helpers"
@@ -1013,6 +1016,12 @@ AC_DEFINE_UNQUOTED(GST_PLUGIN_SCANNER_INSTALLED,
"$GST_PLUGIN_SCANNER_INSTALLED", [location of the installed gst-plugin-scanner])
AC_SUBST(GST_PLUGIN_SCANNER_INSTALLED)
+dnl completion helper locations
+AS_AC_EXPAND(GST_COMPLETION_HELPER_INSTALLED,${libexecdir}/gstreamer-$GST_API_VERSION/gst-completion-helper)
+AC_DEFINE_UNQUOTED(GST_COMPLETION_HELPER_INSTALLED,
+ "$GST_COMPLETION_HELPER_INSTALLED", [location of the installed gst-completion-helper])
+AC_SUBST(GST_COMPLETION_HELPER_INSTALLED)
+
dnl ptp helper locations
AS_AC_EXPAND(GST_PTP_HELPER_INSTALLED,${libexecdir}/gstreamer-$GST_API_VERSION/gst-ptp-helper)
AC_DEFINE_UNQUOTED(GST_PTP_HELPER_INSTALLED,
@@ -1026,6 +1035,7 @@ AG_GST_CHECK_CHECKS
AC_CONFIG_FILES(
Makefile
data/Makefile
+data/bash-completion/helpers/gst
gst/Makefile
gst/gstconfig.h
gst/gstversion.h