summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <edward@centricular.com>2017-07-11 15:29:44 +0200
committerEdward Hervey <bilboed@bilboed.com>2017-07-11 15:31:07 +0200
commitb6064abdfe980c0203f0ab083b5622336b5062f7 (patch)
tree2cd8fa70c6316b0d58accb59fccfebef68ea6d8f /configure.ac
parent2ace5f419191a1fd9e52fd827f51114355713f75 (diff)
pkgconfig: Add private requirements
Add libunwind and dw to the .pc Requires.private. Fixes static library compilation if gstreamer was compiled with one of those dependencies https://bugzilla.gnome.org/show_bug.cgi?id=784795
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58f1944fd..d8ce48771 100644
--- a/configure.ac
+++ b/configure.ac
@@ -802,12 +802,16 @@ dnl libunwind is optionally used by the leaks tracer
PKG_CHECK_MODULES(UNWIND, libunwind, HAVE_UNWIND=yes, HAVE_UNWIND=no)
if test "x$HAVE_UNWIND" = "xyes"; then
AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])
+ UNWIND_REQUIRE=libunwind
+ AC_SUBST(UNWIND_REQUIRE)
fi
dnl libdw is optionally used to add source lines and numbers to backtraces
PKG_CHECK_MODULES(DW, libdw, HAVE_DW=yes, HAVE_DW=no)
if test "x$HAVE_DW" = "xyes"; then
AC_DEFINE(HAVE_DW, 1, [libdw available])
+ DW_REQUIRE=libdw
+ AC_SUBST(DW_REQUIRE)
fi
dnl Check for backtrace() from libc