summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikhail Fludkov <misha@pexip.com>2017-11-10 16:26:50 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-11-24 13:40:34 +0100
commit6577f5e91e9432a9fc7a695e4ac7e250720a9461 (patch)
tree48039f8793da19338fdba1800fb0ee2c64b531f5 /configure.ac
parenteb9ac7436237d18ed1144b745ac69130274afb91 (diff)
gsttraceutils: actually disable tracing system hooks if configured
`./configure --disable-gst-tracer-hooks` didn't do anything, hooks were always enabled regardless of the option. It works correctly in the Meson build though.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f7c83fc8..c0412ed1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,10 @@ AG_GST_CHECK_SUBSYSTEM_DISABLE(GST_DEBUG,[debugging subsystem])
AM_CONDITIONAL(GST_DISABLE_GST_DEBUG, test "x$GST_DISABLE_GST_DEBUG" = "xyes")
AG_GST_CHECK_SUBSYSTEM_DISABLE(GST_TRACER_HOOKS,[tracing subsystem hooks])
AM_CONDITIONAL(GST_DISABLE_GST_TRACER_HOOKS, test "x$GST_DISABLE_GST_TRACER_HOOKS" = "xyes")
+if test "x$GST_DISABLE_GST_TRACER_HOOKS" = xyes; then
+ AC_DEFINE(GST_DISABLE_GST_TRACER_HOOKS, 1,
+ [Define if tracing subsystem hooks is disabled])
+fi
AG_GST_CHECK_SUBSYSTEM_DISABLE(PARSE,[command-line parser])
AM_CONDITIONAL(GST_DISABLE_PARSE, test "x$GST_DISABLE_PARSE" = "xyes")
if test "x$GST_DISABLE_PARSE" = xyes; then