summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2009-06-24 09:28:01 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-06-24 09:28:01 +0100
commitd628988e0a0289fcad302c403f87c9b5128538b9 (patch)
treeea90f01c4566c41bc63cdb4b9d77c7e7e8ef44d0 /Makefile.am
parent3afa91d7aaf4f26b928185a71df4190cab285f28 (diff)
make check: add check for enum type class unrefs in gst_deinit() too
Just because we can really.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5251d660f..d15bc9265 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,21 @@ check-enum-gettypes: $(top_builddir)/gst/gstenumtypes.h
echo " g_type_class_ref ($$f ());"; \
done; \
exit 1; \
+ fi; \
+ echo 'Checking if all enum and flag _get_type() funcs are deinited in gst_deinit()'; \
+ MISSING_FUNCS=''; \
+ for f in $$FUNCS; do \
+ INIT_LINE=`grep $$f $(top_srcdir)/gst/*.c | grep g_type_class_unref`; \
+ if test "x$$INIT_LINE" = "x"; then \
+ MISSING_FUNCS="$$MISSING_FUNCS $$f"; \
+ fi; \
+ done; \
+ if test "x$$MISSING_FUNCS" != "x"; then \
+ echo "FIXME: please add to the following to gst/gst.c gst_deinit():"; \
+ for f in $$MISSING_FUNCS; do \
+ echo " g_type_class_unref (g_type_class_peek ($$f ()));"; \
+ done; \
+ exit 1; \
fi
include $(top_srcdir)/common/coverage/lcov.mak