summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-03-26 17:12:05 +0000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-03-29 10:25:07 +0100
commitc8502ffd733096e24986f8868aab4780037d7b34 (patch)
tree4731149a7205a9bafb754a89c9172c222e2ab41c /Makefile.am
parentffb0a4e1905a873191f8c802346261e8c4435065 (diff)
build: add cruft alert for common/shave*
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e4f0035d..5317b24bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,5 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc --enable-docbook
-all-local: gst-element-check-@GST_MAJORMINOR@.m4
-
-gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
- $(AM_V_GEN)cp gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
-
# note: keep in sync with configure.ac
ACLOCAL_AMFLAGS = -I common/m4 -I .
@@ -155,3 +150,16 @@ endif
endif
check: $(CHECK_EXPORTS) check-enum-gettypes
+
+gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
+ $(AM_V_GEN)cp gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
+
+# cruft: plugins that have been merged or moved or renamed
+
+CRUFT_FILES = \
+ $(top_builddir)/common/shave \
+ $(top_builddir)/common/shave-libtool
+
+include $(top_srcdir)/common/cruft.mak
+
+all-local: gst-element-check-@GST_MAJORMINOR@.m4 check-cruft