summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-11-14 21:28:22 +0000
committerTim-Philipp Müller <tim@centricular.com>2016-11-14 21:28:22 +0000
commitbb14800ba691f4bd2fa0982aa6f7db9da12b6fa3 (patch)
tree2b97703edd72fb589a22561fd029fc8380a44ef1 /Makefile.am
parent6f4891e26fdc02fb92688abc5bc383e8f46ee868 (diff)
win32: remove copies of generated headers
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index e68255c8e..ca8bfe631 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,16 +105,6 @@ build-checks:
echo "'check' library not installed, skipping"
endif
-# FIXME: this target should be run every time we do "make release"
-# find a way of automating that
-win32-update:
- for f in gstversion.h gstenumtypes.c gstenumtypes.h; do \
- cp $(top_builddir)/gst/$$f win32/common; done
- $(top_srcdir)/tools/gst-indent win32/common/gstenumtypes.c
- $(top_srcdir)/tools/gst-indent win32/common/gstenumtypes.c
- cp $(top_builddir)/win32/common/config.h-new \
- $(top_srcdir)/win32/common/config.h
-
check-enum-gettypes: $(top_builddir)/gst/gstenumtypes.h
@echo 'Checking if all enum and flag _get_type() funcs are inited in gst_init()'; \
FUNCS=`grep '_get_type (' gst/gstenumtypes.h | sed -e 's/^.*gst_/gst_/' -e 's/_get_type.*$$/_get_type/'`;\
@@ -164,6 +154,7 @@ gst-element-check-@GST_API_VERSION@.m4: gst-element-check.m4
# cruft: plugins that have been merged or moved or renamed
CRUFT_FILES = \
+ $(top_builddir)/win32/common/config.h-new \
$(top_builddir)/common/shave \
$(top_builddir)/common/shave-libtool \
$(top_builddir)/common/m4/codeset.m4 \