summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2012-04-04 13:13:52 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2012-04-04 14:28:55 +0200
commitb0d89da6b66021bc8677b9785998b12b6a00676a (patch)
tree5e4ce2dffca4125e05d96bf47b1fb17b61cd1217 /Makefile.am
parent6a0e594ebcadbe8d9e32819579072920ef422274 (diff)
gst: Change versioning
Remove GST_MAJORMINOR and replace it by GST_API_VERSION Also set GST_VERSION_{MAJOR,MINOR,MICRO,NANO} explicitely now. All versions are at 1.0.0 now for the release soon but API/ABI can still change until the 1.0.0 release. Next release versions until 1.0.0 will be 0.10.9X and these will be release candidates. GST_VERSION_* will nonetheless stay at 1.0.0.0.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e39b86df5..671aec1ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc --enable-docbook
ACLOCAL_AMFLAGS = -I m4 -I common/m4
aclocaldir = $(datadir)/aclocal
-aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
+aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
SUBDIRS = pkgconfig \
gst libs plugins tools tests \
@@ -32,7 +32,7 @@ EXTRA_DIST = \
scripts/gst-uninstalled \
$(win32)
-CLEANFILES = gst-element-check-@GST_MAJORMINOR@.m4
+CLEANFILES = gst-element-check-@GST_API_VERSION@.m4
DISTCLEANFILES = _stdint.h
@@ -148,8 +148,8 @@ endif
check: $(CHECK_EXPORTS) check-enum-gettypes
-gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
- $(AM_V_GEN)cp gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
+gst-element-check-@GST_API_VERSION@.m4: gst-element-check.m4
+ $(AM_V_GEN)cp gst-element-check.m4 gst-element-check-@GST_API_VERSION@.m4
# cruft: plugins that have been merged or moved or renamed
@@ -198,4 +198,4 @@ CRUFT_DIRS = \
include $(top_srcdir)/common/cruft.mak
-all-local: gst-element-check-@GST_MAJORMINOR@.m4 check-cruft
+all-local: gst-element-check-@GST_API_VERSION@.m4 check-cruft