summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2012-06-07 11:30:48 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2012-06-26 23:12:56 +0100
commit8b3708ea8cf591c891bad2b9655b14923640d0bf (patch)
tree1086ef261887812f019af5495208fc36b52502cb /Makefile.am
parent2c532aa821e540a460b2daed66a5190345002a96 (diff)
configure: add --disable-tools and --disable-benchmarks options
Add option to avoid build binaries. When building for platforms like android, you might want to not link any "final" binary, mostly because it requires special link flags or other parts of code that aren't in the C library. https://bugzilla.gnome.org/show_bug.cgi?id=677621
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 671aec1ee..c8fe12a8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,12 +7,16 @@ aclocaldir = $(datadir)/aclocal
aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
SUBDIRS = pkgconfig \
- gst libs plugins tools tests \
+ gst libs plugins tests \
docs \
po \
m4 \
common
+if BUILD_TOOLS
+SUBDIRS += tools
+endif
+
# These are all the possible subdirs
DIST_SUBDIRS = pkgconfig \
gst libs plugins tools tests \