summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2006-11-09 14:37:38 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2006-11-09 14:37:38 +0000
commit6f363cd89b123d191fd46dba7aa472262f184c3f (patch)
treeed7f97c292de55d821f211aa5728e249dc726b43 /Makefile.am
parent556694624153a9c6e542b322086a085fd6a51dcd (diff)
Do some optimisation work in GstAdapter to avoid copies in more cases.
Original commit message from CVS: * Makefile.am: * configure.ac: * libs/gst/base/gstadapter.c: (gst_adapter_clear), (gst_adapter_push), (gst_adapter_peek_into), (gst_adapter_peek), (gst_adapter_flush), (gst_adapter_take), (gst_adapter_take_buffer): * libs/gst/base/gstadapter.h: * tests/check/libs/adapter.c: (create_and_fill_adapter), (GST_START_TEST), (gst_adapter_suite): * tests/examples/Makefile.am: Do some optimisation work in GstAdapter to avoid copies in more cases. It could still do slightly better by merging buffers when gst_buffer_is_span_fast is true, but is already faster. Also, avoid traversing a single-linked list to append each incoming buffer inside the adapter. Add simple test app that times the adapter behaviour in different situations, and extend the unit test to check that bytes enter and exit the adapter in their original order.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7472ca77d..86539d5af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,7 +50,7 @@ clean-bbg:
GCOV_DIRS=gst libs
## .PHONY so it always rebuilds it
-.PHONY: coverage-report.txt test-coverage-report.html
+.PHONY: coverage-report.txt test-coverage-report.html lcov
coverage-report.txt:
BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \