summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-12-12 23:20:00 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-12-12 23:20:00 +0000
commit0ef9a5f5b16a9247fba6a0f6298ce912b27bbbea (patch)
tree7029e22cc6fb6bd0008a73e105ec8e44e7e33a9e /Makefile.am
parent4fffa41e1c9028afd23ff60e02b07aa46d5a9339 (diff)
Makefile.am: Add check-exports target and run it as part of 'make check' (see #499140 and #493983).
Original commit message from CVS: * Makefile.am: Add check-exports target and run it as part of 'make check' (see #499140 and #493983). * gst/gst_private.h: * gst/gstelementfactory.h: * gst/gstghostpad.c: (gst_proxy_pad_class_init): * gst/gstinfo.c: (_priv_gst_in_valgrind), (_gst_debug_init), (_priv_gst_in_valgrind): * gst/gstinfo.h: (GstLogFunction): * gst/gsttypefind.c: (type_find_debug), (GST_CAT_DEFAULT), (gst_type_find_register): * gst/gsttypefindfactory.c: (type_find_debug), (GST_CAT_DEFAULT), (gst_type_find_factory_get_type): * libs/gst/controller/gstcontroller.c: (GST_CAT_DEFAULT), (GST_CAT_DEFAULT), (parent_class), (priv_gst_controller_key), (gst_controller_new_valist), (gst_controller_new_list), (_gst_controller_dispose), (_gst_controller_class_init): * libs/gst/controller/gstcontrolsource.c: (GST_CAT_DEFAULT): * libs/gst/controller/gsthelper.c: (GST_CAT_DEFAULT), (GST_CAT_DEFAULT), (gst_object_uncontrol_properties), (gst_object_get_controller), (gst_object_set_controller), (gst_object_suggest_next_sync), (gst_object_sync_values), (gst_object_set_control_source), (gst_object_get_control_source), (gst_object_get_value_arrays), (gst_object_get_value_array), (gst_object_get_control_rate), (gst_object_set_control_rate): * libs/gst/controller/gstinterpolation.c: (GST_CAT_DEFAULT): * libs/gst/controller/lib.c: (GST_CAT_DEFAULT): Make some functions that should be static static; rename some private symbols so that they don't get exported; add some FIXME comments so we can move accidentally exported functions into our private section in 0.11. * win32/common/libgstreamer.def: Add gst_utils_get_timestamp().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 67abb18f1..098b82ce9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,3 +112,21 @@ win32-update:
$(top_srcdir)/tools/gst-indent win32/common/gstenumtypes.c
include $(top_srcdir)/common/coverage/lcov.mak
+
+# make sure all symbols we export on linux are defined in the win32 .def too
+# (don't care about other unixes for now, it's enough if it works on one of
+# the linux build bots; we assume .so )
+corelibs='libgstreamer libgstbase libgstcontroller libgstdataprotocol libgstnet'
+check-exports:
+ for l in `eval echo $(corelibs)`; do \
+ libso=`find "$(top_builddir)" -name "$$l-0.10.so"`; \
+ libdef="$(top_srcdir)/win32/common/$$l.def"; \
+ if test "x$$libso" != "x"; then \
+ echo Checking symbols in $$libso; \
+ $(top_srcdir)/common/check-exports $$libdef $$libso || exit 1; \
+ fi; \
+ done
+
+check: check-exports
+
+