summaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index c45755e..cf36182 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -10,7 +10,11 @@ all-local: $(pcfiles) $(pcfiles_uninstalled)
%-@GST_API_VERSION@.pc: %.pc
cp $< $@
%-@GST_API_VERSION@-uninstalled.pc: %-uninstalled.pc
- cp $< $@
+### the uninstalled libdir is depend of the build system used so set it here
+### rather than hardcoding it in the file directly.
+ $(AM_V_GEN) sed \
+ -e "s|[@]rtspserverlibdir[@]|$(abs_top_builddir)/gst/rtsp-server/.libs|" \
+ $< > $@.tmp && mv $@.tmp $@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = $(pcfiles)