summaryrefslogtreecommitdiff
path: root/gst-libs/gst/video/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/video/Makefile.am')
-rw-r--r--gst-libs/gst/video/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gst-libs/gst/video/Makefile.am b/gst-libs/gst/video/Makefile.am
index 49d52b8e6..9fc1ccfca 100644
--- a/gst-libs/gst/video/Makefile.am
+++ b/gst-libs/gst/video/Makefile.am
@@ -8,7 +8,8 @@ glib_enum_headers = video.h video-format.h video-color.h video-info.h video-dith
glib_enum_define = GST_VIDEO
glib_gen_prefix = gst_video
glib_gen_basename = video
-glib_gen_decl_banner=GST_EXPORT
+glib_gen_decl_banner=GST_VIDEO_API
+glib_gen_decl_include=\#include <gst/video/video-prelude.h>
built_sources = video-enumtypes.c
built_headers = video-enumtypes.h
@@ -60,6 +61,7 @@ libgstvideo_@GST_API_VERSION@include_HEADERS = \
colorbalancechannel.h \
navigation.h \
video.h \
+ video-prelude.h \
video-event.h \
video-format.h \
video-chroma.h \