summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-01-30 20:32:44 +0000
committerTim-Philipp Müller <tim@centricular.com>2018-01-30 20:33:17 +0000
commitc443e33a3a46c8e8aba260e4554fadffa655efcd (patch)
tree876c3c56b2f7707a58b65664ade003b719722609 /meson.build
parent17b118c12049a80a6d0083798782d78c26a6cf04 (diff)
meson: use built-in pic kwarg when building static helper libs
instead of passing -fPIC manually.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 80930ce12..073a40179 100644
--- a/meson.build
+++ b/meson.build
@@ -215,14 +215,6 @@ have_sse = cc.has_argument(sse_args)
have_sse2 = cc.has_argument(sse2_args)
have_sse41 = cc.has_argument(sse41_args)
-# FIXME: Meson should have a way for portably adding -fPIC when needed for use
-# with static libraries that are linked into shared libraries. Or, it should
-# add it by default with an option to turn it off if needed.
-pic_args = ['-fPIC']
-if host_machine.system() == 'windows'
- pic_args = []
-endif
-
if gst_dep.type_name() == 'internal'
gst_proj = subproject('gstreamer')