summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2016-10-26 22:37:19 -0700
committerTim-Philipp Müller <tim@centricular.com>2016-11-11 15:59:19 +0000
commit9ce939a9ae889ca2e6198e595b6b8993282c0e59 (patch)
tree4dbb703c01631c2c97ccc86dbcfc6e9ca760a9b4 /meson.build
parent30b305578095c1ef29f20836fa0e0a1d882c509f (diff)
meson: don't add_global_arguments when being built as a subproject
https://bugzilla.gnome.org/show_bug.cgi?id=773568
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7f2dbc0cf..1ebde0ab6 100644
--- a/meson.build
+++ b/meson.build
@@ -35,7 +35,9 @@ if cc.get_id() == 'msvc'
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once
# NOTE: Only add warnings here if you are sure they're spurious
- add_global_arguments('/wd4018', '/wd4244', '/wd4996', language : 'c')
+ if not meson.is_subproject()
+ add_global_arguments('/wd4018', '/wd4244', '/wd4996', language : 'c')
+ endif
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW
noseh_link_args = ['/SAFESEH:NO']