summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2016-10-26 22:36:17 -0700
committerTim-Philipp Müller <tim@centricular.com>2016-11-11 16:55:38 +0000
commitba2908aa2c28a50de84231e9f93ca9032f3eb608 (patch)
tree06174188b66c6f9df71bf3fe94f11d2cdfc02643 /meson.build
parentba6b8c33e03b4df06e13fc571678752163de3b3f (diff)
meson: don't add_global_arguments when being built as a subproject
https://bugzilla.gnome.org/show_bug.cgi?id=773568
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a46df0c4c..04ba44180 100644
--- a/meson.build
+++ b/meson.build
@@ -33,7 +33,9 @@ if cc.get_id() == 'msvc'
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once
# NOTE: Only add warnings here if you are sure they're spurious
- add_global_arguments('/wd4018', '/wd4146', '/wd4244', '/wd4333', '/wd4996', language : 'c')
+ if not meson.is_subproject()
+ add_global_arguments('/wd4018', '/wd4146', '/wd4244', '/wd4333', '/wd4996', language : 'c')
+ endif
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW
noseh_link_args = ['/SAFESEH:NO']