summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorg Lippitsch <glippitsch@toolsonair.com>2017-06-13 13:19:19 +0300
committerVivia Nikolaidou <vivia@ahiru.eu>2017-11-07 16:45:52 +0200
commitc01afab9f7fa7e822dea38e358e92163e8d36282 (patch)
tree2217c087bef501ec0d7e3e375606906ac0a60efc /configure.ac
parent595254f21b15702d95d5a7cf6e43d29f9c179f43 (diff)
timecodestamper: LTC from audio
Add support for parsing linear time code from an audio source using libltc https://github.com/x42/libltc The user can now choose between 3 different and independently running timecode sources. The old override-existing property has been replaced by timecode-source. https://bugzilla.gnome.org/show_bug.cgi?id=784295
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b5c4fbe3..b6a4ef130 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3420,6 +3420,13 @@ AG_GST_CHECK_FEATURE(WEBRTCDSP, [WebRTC Audio Processing], webrtcdsp, [
AC_LANG_POP([C++])
])
+dnl *** libltc ***
+PKG_CHECK_MODULES(LIBLTC, ltc >= 1.1.4, HAVE_LTC=yes, HAVE_LTC=no)
+if test "x$HAVE_LTC" = "xyes"; then
+ LIBS="$LIBS -lltc"
+ AC_DEFINE(HAVE_LTC, 1, [Use libltc])
+fi
+
else
dnl not building plugins with external dependencies,