summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-26 18:21:44 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-26 18:21:44 +0000
commit8e7deaab80e9d80b3185ec8b07ec306176bc6328 (patch)
tree47a39d5736c0a7f6588454db4eea3ba8fb47eb9b /Makefile.am
parentc1aac95ee4b5ef4a6adbdfbee7672f1dad1f9316 (diff)
releasing
Original commit message from CVS: releasing
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c553c6..53247ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,2 +1,17 @@
SUBDIRS = gst-libs ext
EXTRA_DIST=gst-ffmpeg.spec
+
+# to do a release, run "make release"
+# this will generate all archives and md5sums
+
+# make bz2 as well
+AUTOMAKE_OPTIONS = dist-bzip2
+
+release: dist
+ make @PACKAGE@-@VERSION@.tar.gz.md5
+ make @PACKAGE@-@VERSION@.tar.bz2.md5
+
+# generate md5 sum files
+%.md5: %
+ md5sum $< > $@
+