summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCedric Bail <cedric.bail@samsung.com>2013-12-09 21:35:56 +0900
committerCedric Bail <cedric.bail@samsung.com>2013-12-09 21:36:41 +0900
commit6f50fc9d63f9448d87e14e954d28e0f7a6bd3fd3 (patch)
tree24381768a4f0e3a3efcd14897b9fb15448d067a9 /configure.ac
parentcb3fcca0e7f6af0dd095a0ea5ec0f2360ab4269d (diff)
autotools: work around buggy macro to force C++ compiler detection.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3c701920d..edc12072e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -283,7 +283,11 @@ AM_PROG_CC_C_O
if test "x${ac_cv_prog_cc_c99}" = "xno" ; then
AC_MSG_ERROR([efl requires a c99-capable compiler])
fi
-if test "x${CXX}" = "x"; then
+# We should be using ${CXX} here, but there is a bug in
+# autotools macro and CXX is always set to g++ even if
+# it's not found. So we are using an internal variable
+# that does the work for now, may get broken in the future.
+if test "x${ac_ct_CXX}" = "x"; then
AC_MSG_ERROR([efl requires a C++ compiler])
fi