summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel Burt <gabriel.burt@gmail.com>2010-03-08 20:28:39 -0800
committerGabriel Burt <gabriel.burt@gmail.com>2010-03-09 13:45:54 -0800
commit28f6588cfa420c18ebb2eae6a7c4c1922a7ce84f (patch)
tree19ecd873b5f97c575adb68384c78bba94045508c /Makefile.am
parent0d1ee0961f71effc512ae30f9c05ce16b1a5ebad (diff)
[Mirage] Make RandomBySimilar much more sophisticated
Now uses weighted seeds to find the next song, weighing the similarity to manually-added (eg in Play Queue) songs the highest, then played songs, then shuffled, upcoming songs, and then finally it looks for songs dissimilar to ones you've skipped or discarded (eg removed from the Play Queue). Currently only compares against the most recent few from each seed category.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 251ed32..a4beddd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,7 @@ clean-local:
# copy the extension dlls to such a folder so Banshee will pick them up.
run:
(cd bin; mkdir -p addins; cp *.dll* addins/; \
+ export LD_LIBRARY_PATH=".${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}"; \
banshee-1 --uninstalled --debug $(BANSHEE_DEV_OPTIONS) \
)