summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-02-08 20:08:52 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-08 20:09:41 -0500
commitd9a142d60603920069f478890884f20cbd7886b3 (patch)
tree3a20e339e5e9d7827433a8c8669dc12833dc54a0 /configure.ac
parent269276497a4f452cc943afe0eb9072519621d36e (diff)
config: move compiler flags from configure.ac to Makefile.am
CFLAGS is an automake defined variable that should not be set by the module. It should not be AC_SUBST either, it already is. Use AM_CFLAGS in Makefile.am. This will allow the user to override the flags as they will be in the right order. The -g option is already part of the default flags. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 792bf6a..2ee4985 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,14 +73,6 @@ if test "x$XSERVER_LIBPCIACCESS" = xyes; then
fi
AM_CONDITIONAL(XSERVER_LIBPCIACCESS, test "x$XSERVER_LIBPCIACCESS" = xyes)
-# blah, should be XORG_CWARNFLAGS
-if test "x$GCC" = xyes ; then
- CWARNFLAGS="-Wall -Wstrict-prototypes -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wold-style-definition -Wbad-function-cast -Wdeclaration-after-statement"
-fi
-
-CFLAGS="$CFLAGS $CWARNFLAGS $XORG_CFLAGS "
-AC_SUBST([CFLAGS])
-
# Checks for libraries.
# Checks for header files.