summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSoeren Sandmann <sandmann@redhat.com>2006-01-14 23:26:34 +0000
committerSøren Sandmann Pedersen <ssp@src.gnome.org>2006-01-14 23:26:34 +0000
commit98308836afa4b0a690373716e3de3823bc399150 (patch)
tree426400025edd471f3dd3a680e26100667769c256 /configure.ac
parent9125c4e644fa8168b6f6b15f06cda7423deec996 (diff)
Only build GUI when the necessary dependencies are found.
Sat Jan 14 18:24:43 2006 Soeren Sandmann <sandmann@redhat.com> * configure.ac, Makefile.am: Only build GUI when the necessary dependencies are found. * sysprof.c (compute_text_width): Remove unused variable * profile.c (build_object_list): Follow next instead of siblings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9962d0f..6523b08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,11 +86,12 @@ fi
core_dep="glib-2.0"
gui_dep="gtk+-2.0 > 2.6.0 gdk-pixbuf-2.0 pangoft2 libglade-2.0"
-PKG_CHECK_MODULES(CORE_DEP, $core_dep, [],
- AC_MSG_ERROR([sysprof dependencies not satisfied]))
+PKG_CHECK_MODULES(CORE_DEP, $core_dep, [], AC_MSG_ERROR([sysprof dependencies not satisfied]))
-PKG_CHECK_MODULES(GUI_DEP, $gui_dep, [],
- AC_MSG_ERROR([sysprof dependencies not satisfied]))
+build_gui=yes
+PKG_CHECK_MODULES(GUI_DEP, $gui_dep, [], build_gui=no)
+
+AM_CONDITIONAL([BUILD_GUI], [test "$build_gui" = yes])
# libiberty and libbfd