summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@nokia.com>2009-06-24 01:30:34 +0300
committerJeff Muizelaar <jmuizelaar@mozilla.com>2009-06-25 08:07:37 -0700
commit9837465fd9a5d4e7280d4c79c41d2d9a9c8f71c0 (patch)
treee1de744cc75188eb8ae3821791c094f890024173 /configure.ac
parent6b8251039a905114e4b0776c3f8f58cb0678a532 (diff)
Use -mcpu instead of -march for ARM SIMD runtime autodetection
Option -mcpu has higher priority than -march with the current versions of gcc and that's why it is better to use. There is no particular reason why 'arm1136j-s' is used in this patch, it could be any armv6 compatible core.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8ed9149c..b5ea19c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,7 +327,7 @@ AM_CONDITIONAL(USE_VMX, test $have_vmx_intrinsics = yes)
dnl ===========================================================================
dnl Check for ARM SIMD instructions
-ARM_SIMD_CFLAGS="-march=armv6"
+ARM_SIMD_CFLAGS="-mcpu=arm1136j-s"
have_arm_simd=no
AC_MSG_CHECKING(whether to use ARM SIMD assembler)