summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2008-09-11 15:49:09 -0400
committerBehdad Esfahbod <behdad@behdad.org>2008-09-11 15:49:09 -0400
commitde5b8bce37f2ddb87fca7ae6b844eec7fbbbc7e9 (patch)
tree9d1d49b0b786518457a8cb6b226463955b9110fc /Makefile.am
parent66f0d56a8a2c8dd3b4678d495d5652bfdfd690ea (diff)
Makefile.am cleanup
Use a common build/Makefile.am.common file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b55262d..48ac8551 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+include $(top_srcdir)/build/Makefile.am.common
+
ACLOCAL_AMFLAGS = -I build
DIST_SUBDIRS = src boilerplate test perf doc util
@@ -21,7 +23,7 @@ check-valgrind: all
.PHONY: doc test retest recheck perf check-valgrind
-EXTRA_DIST = \
+EXTRA_DIST += \
AUTHORS \
BIBLIOGRAPHY \
BUGS \
@@ -40,8 +42,8 @@ EXTRA_DIST = \
cairo-version.h \
$(NULL)
-DISTCLEANFILES = config.cache
-MAINTAINERCLEANFILES = \
+DISTCLEANFILES += config.cache
+MAINTAINERCLEANFILES += \
$(srcdir)/aclocal.m4 \
$(srcdir)/autoscan.log \
$(srcdir)/build/compile \
@@ -54,11 +56,12 @@ MAINTAINERCLEANFILES = \
$(srcdir)/build/mkinstalldirs \
$(srcdir)/config.h.in \
$(srcdir)/configure.scan \
- `find "$(srcdir)" -type f -name Makefile.in -print`
+ $(NULL)
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
- --enable-test-surfaces
+ --enable-test-surfaces \
+ $(NULL)
include $(srcdir)/build/Makefile.am.changelog
include $(srcdir)/build/Makefile.am.releasing