summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLouis-Francis Ratté-Boulianne <louis-francis.ratte-boulianne@collabora.co.uk>2010-08-18 14:02:11 -0400
committerSimon McVittie <smcv@debian.org>2010-08-26 11:37:13 +0100
commit0ed654e18e29f8c23add3d69e57f6b3628c8f848 (patch)
treeb595db6698521ab85a0bc785501977013e801b35 /configure.ac
parentf68a143ac3b19bd40709cbc85b5112fcb0d2e07b (diff)
Don't override CFLAGS when adding compiler warnings
Macro function TP_COMPILER_WARNINGS overrides the value of the given variable (first argument of the function) Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index db5f76e..eb71a55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,7 +144,7 @@ AC_CHECK_LIB([dbus-1], [dbus_watch_get_unix_fd],
[Define if libdbus-1 has dbus_watch_get_unix_fd])],
[:], [$DBUS_LIBS])
-TP_COMPILER_WARNINGS([CFLAGS], [test] dbus_python_released [= 0],
+TP_COMPILER_WARNINGS([CFLAGS_WARNINGS], [test] dbus_python_released [= 0],
[all \
extra \
declaration-after-statement \
@@ -160,6 +160,8 @@ TP_COMPILER_WARNINGS([CFLAGS], [test] dbus_python_released [= 0],
init-self],
[missing-field-initializers])
+CFLAGS="$CFLAGS $CFLAGS_WARNINGS"
+
JH_ADD_CFLAG([-std=c9x])
JH_ADD_CFLAG([-fno-strict-aliasing])