summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-05-04 19:51:50 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-05-07 16:41:40 +0100
commit863cec2464edd80fcf7fbdf62cf1c89ecab647d0 (patch)
treecf4e0a29a4a5975518ca7fb799c5c77cbf2a2d70 /Makefile.am
parent727fa4079d91f8dd1b301e21d3e4279c202a9739 (diff)
Create doc directory before writing HTML into it
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 38a4208..f2d0232 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,9 +55,10 @@ nodist_doc_DATA = $(HTML_TXT_RSTDOCS) $(HTML_RSTDOCS)
CLEANFILES += $(nodist_doc_DATA)
$(HTML_TXT_RSTDOCS) : %.html: %.txt
- $(RST2HTML) $(RST2HTMLFLAGS) $< $@
+ $(INSTALL) -d doc
+ $(RST2HTML) $(RST2HTMLFLAGS) $< $@
$(HTML_RSTDOCS) : %.html: %
- $(RST2HTML) $(RST2HTMLFLAGS) $< $@
+ $(RST2HTML) $(RST2HTMLFLAGS) $< $@
else
_maintainer-update-htmldocs:
@echo "*** Not updating the HTML docs on the website - install rst2html"