summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-02 10:41:27 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-02 10:41:27 +0100
commit5b9f87676802f04ebc339fd16a4a30dc42e33c91 (patch)
tree1ce535bdfa5662b9ccb66503d1bb4e9eeabce2d9 /Makefile.am
parentba3f3ff253982c9ad3b5a33df5b120e5692c9d29 (diff)
Reinstate the old dbus.gobject_service, but only for Python 2
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=48904
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f244061..ebc2e43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,12 @@ nobase_python_PYTHON = \
dbus/service.py \
dbus/types.py
+if !HAVE_PYTHON_3
+nobase_python_PYTHON += \
+ dbus/gobject_service.py \
+ $(NULL)
+endif
+
check_py_sources = $(nobase_python_PYTHON)
include $(top_srcdir)/tools/check-coding-style.mk