summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-08-06 14:26:21 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-08-06 14:26:21 +0100
commit050bf4a893e24061c3de35eb24c05d3d1002ed28 (patch)
tree33033f0f8306c04f1cf122a90015bce6ba9bb7ba /Makefile.am
parent33773b778911c890d76c38b13f0fdb39df237d9e (diff)
Makefile.am, test/Makefile.am: Use @abs_top_builddir@, @abs_top_srcdir@
This fixes incorrect Python path for docs and tests if doing an out-of-tree build using an absolute path for $(srcdir), and is also less ugly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e00f70..56e19d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,6 @@
+abs_top_srcdir = @abs_top_srcdir@
+abs_top_builddir = @abs_top_builddir@
+
ACLOCAL_AMFLAGS = -I m4
# the api, doc, include subdirs don't need their own Makefile.am
@@ -80,8 +83,7 @@ _dbus_bindings/_dbus_bindings.la:
_dbus_glib_bindings/_dbus_glib_bindings.la:
$(MAKE) -C _dbus_glib_bindings
-PWD = `pwd`
-APIDOC_PYTHONPATH = $(PWD)/$(top_srcdir):$(PWD)/_dbus_bindings/.libs:$(PWD)/_dbus_glib_bindings/.libs
+APIDOC_PYTHONPATH = $(abs_top_srcdir):$(abs_top_builddir)/_dbus_bindings/.libs:$(abs_top_builddir)/_dbus_glib_bindings/.libs
api api/index.html: $(python_PYTHON) dbus/.doc-needs-rebuild-stamp \
_dbus_bindings/_dbus_bindings.la \