summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-10-28 10:04:12 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2012-10-28 10:13:04 +0000
commitf18199fcfb3b052c198041fc05156ae3d9e6aee7 (patch)
tree2cebda0313adaeed18054e66d06867e21c235deb /configure.ac
parentd57e652f08f5ff7c334d01bc071962e6a131928f (diff)
xlib/shm: Check for XShm headers
Not all version of libXext ship the same set of headers, so play safe and check during configure that we have the headers we depend upon in the code. Reported-by: Sebastian Haas <sehaas@gmail.com> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7adbeb125..021ec8e2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,10 @@ CAIRO_ENABLE_SURFACE_BACKEND(xlib, Xlib, auto, [
AC_MSG_RESULT(no),
AC_MSG_RESULT(assuming no))
fi
+
+ AC_CHECK_HEADERS([X11/extensions/XShm.h X11/extensions/shmproto.h], [], [],
+ [#include <X11/Xlibint.h>
+ #include <X11/Xproto.h>])
])
CAIRO_ENABLE_SURFACE_BACKEND(xlib_xrender, Xlib Xrender, auto, [