summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrea Canciani <ranma42@gmail.com>2012-02-16 19:21:47 +0100
committerAndrea Canciani <ranma42@gmail.com>2012-02-16 23:00:46 +0100
commited803a193585544d2c4a290e95700cf9b68d0f10 (patch)
treedb42d04434c8c273f74ef28d4e8cdca22ca9b921 /Makefile.am
parentc60627e8af240189a16d7118230bf6df6d300f21 (diff)
build: Add 'clean' target to Makefile.win32 build system
The Makefile.win32 in the subdirectories provide a working 'clean' target (defined in Makefile.win32.common), the central Makefile.win32 'clean' target does not do anything. Replace the noop 'clean' target with one that cleans all the subdirs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am83
1 files changed, 83 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c03294..e7f59d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -0,0 +1,83 @@
+include $(top_srcdir)/build/Makefile.am.common
+
+EXTRA_DIST += \
+ KNOWN_ISSUES \
+ README.win32 \
+ Makefile.win32 \
+ build/Makefile.win32.common \
+ build/Makefile.win32.inform \
+ build/Makefile.win32.features \
+ build/Makefile.win32.features-h \
+ $(NULL)
+#MAINTAINERCLEANFILES += \
+# $(srcdir)/build/Makefile.win32.features \
+# $(srcdir)/build/Makefile.win32.features-h \
+# $(NULL)
+
+ACLOCAL_AMFLAGS = -I build
+
+DIST_SUBDIRS = src doc util boilerplate test perf
+SUBDIRS = src doc util
+# libpng is required for our test programs
+if CAIRO_HAS_PNG_FUNCTIONS
+SUBDIRS += boilerplate test perf
+endif
+
+configure: cairo-version.h
+
+doc:
+ cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
+test retest recheck: all
+ cd test && $(MAKE) $(AM_MAKEFLAGS) $@
+perf: all
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) $@
+check-valgrind: all
+ cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+.PHONY: doc test retest recheck perf check-valgrind
+
+
+EXTRA_DIST += \
+ AUTHORS \
+ BIBLIOGRAPHY \
+ BUGS \
+ CODING_STYLE \
+ COPYING \
+ COPYING-LGPL-2.1 \
+ COPYING-MPL-1.1 \
+ HACKING \
+ INSTALL \
+ NEWS \
+ PORTING_GUIDE \
+ README \
+ RELEASING \
+ autogen.sh \
+ cairo-version.h \
+ $(NULL)
+
+DISTCLEANFILES += config.cache
+
+MAINTAINERCLEANFILES += \
+ $(srcdir)/aclocal.m4 \
+ $(srcdir)/autoscan.log \
+ $(srcdir)/build/compile \
+ $(srcdir)/build/config.guess \
+ $(srcdir)/build/config.sub \
+ $(srcdir)/build/depcomp \
+ $(srcdir)/build/install-sh \
+ $(srcdir)/build/ltmain.sh \
+ $(srcdir)/build/missing \
+ $(srcdir)/build/mkinstalldirs \
+ $(srcdir)/config.h.in \
+ $(srcdir)/configure.scan \
+ $(NULL)
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-gtk-doc \
+ --enable-test-surfaces \
+ --enable-full-testing \
+ $(NULL)
+
+include $(srcdir)/build/Makefile.am.changelog
+include $(srcdir)/build/Makefile.am.releasing
+include $(srcdir)/build/Makefile.am.analysis