summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 481d0bb..5691702 100644
--- a/configure.ac
+++ b/configure.ac
@@ -647,6 +647,19 @@ if test $enable_timers = yes ; then
fi
AC_SUBST(PIXMAN_TIMERS)
+dnl ==============================================
+dnl Worker thread
+
+AC_ARG_ENABLE(worker-thread,
+ [AC_HELP_STRING([--enable-worker-thread],
+ [enable parallel threaded compositing [default=no]])],
+ [enable_worker_thread=$enableval], [enable_worker_thread=no])
+
+if test $enable_worker_thread = yes ; then
+ AC_DEFINE(PIXMAN_USE_WORKER_THREAD, 1, [enable parallel threaded compositing])
+fi
+AC_SUBST(PIXMAN_USE_WORKER_THREAD)
+
dnl ===================================
dnl GTK+