summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@nokia.com>2010-09-13 04:21:33 +0300
committerSiarhei Siamashka <siarhei.siamashka@nokia.com>2011-01-16 23:40:34 +0200
commit2bbd553bd21dcc1b199eb11ec6cb78a5b9769d49 (patch)
tree337fbbfab1d19e47ba908affde0b82b68a805133 /configure.ac
parent55bbccf84e475b2e3c4536606cd08c946c041fd0 (diff)
A new configure option --enable-static-testprogs
This option can be used for building fully static binaries of the test programs so that they can be easily run using qemu-user. With binfmt-misc configured, 'make check' works fine for crosscompiled pixman builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2570c84..6552f12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -566,6 +566,20 @@ fi
AM_CONDITIONAL(USE_GCC_INLINE_ASM, test $have_gcc_inline_asm = yes)
dnl ==============================================
+dnl Static test programs
+
+AC_ARG_ENABLE(static-testprogs,
+ [AC_HELP_STRING([--enable-static-testprogs],
+ [build test programs as static binaries [default=no]])],
+ [enable_static_testprogs=$enableval], [enable_static_testprogs=no])
+
+TESTPROGS_EXTRA_LDFLAGS=
+if test "x$enable_static_testprogs" = "xyes" ; then
+ TESTPROGS_EXTRA_LDFLAGS="-all-static"
+fi
+AC_SUBST(TESTPROGS_EXTRA_LDFLAGS)
+
+dnl ==============================================
dnl Timers
AC_ARG_ENABLE(timers,