summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-04-27 01:06:46 -0700
committerJosh Triplett <josh@freedesktop.org>2006-04-27 01:06:46 -0700
commitefbe654893e6b443218417b49e3db5d541ff28c5 (patch)
tree9c1b8b219d2a2f20d510429835eb9514ee54b1dd /configure.ac
parentc6fab7e8addb8793210afbf011c2d00abe522e82 (diff)
Fix xcb-util library dependencies, including both the new dependency libXCBImage needs on libXCBShm, as well as many other issues discovered in the process. These include using automake variables appropriately in order to actually link shared libraries against each other and ensure libraries have NEEDED entries for the libraries they depend on, consequently needing to reorder the top-level SUBDIRS to build property before icccm, adding dependencies to .pc.in files, fixing .pc.in files to not all use the name and description for XCBImage, and adding appropriate library dependencies to test programs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f5bbd7..90d75e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,7 @@ pkgconfigdir='${libdir}/pkgconfig'
AC_SUBST(pkgconfigdir)
PKG_CHECK_MODULES(XCB, xcb)
+PKG_CHECK_MODULES(XCB_SHM, xcb-shm)
AC_OUTPUT([Makefile
convenient/Makefile convenient/xcb-aux.pc