summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-06-07 12:06:00 -0700
committerJamey Sharp <jamey@minilop.net>2006-11-12 18:08:41 -0800
commite61fc10ae25a075bc360d3e290ef5c21d629a547 (patch)
treee6039f396717cc13aaaa5c0af342e1f5e14aff4a /configure.ac
parentcbbdf0f622ed3a8642e30198940e24117baaf55e (diff)
Bug #7150: Check for gcc & Sun cc in configure.ac and use correct flags to turn on more warnings for each
This is the first of two fixes needed to get xcb-util building on Solaris. Signed-off-by: Jamey Sharp <jamey@minilop.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b3c4ba..1204b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,16 @@ fi
AC_PROG_CC
AC_PROG_LIBTOOL
+if test "x$GCC" = xyes ; then
+ CWARNFLAGS="-Wall"
+else
+ AC_CHECK_DECL([__SUNPRO_C], [SUNCC="yes"], [SUNCC="no"])
+ if test "x$SUNCC" = "xyes"; then
+ CWARNFLAGS="-v"
+ fi
+fi
+AC_SUBST(CWARNFLAGS)
+
xcbincludedir='${includedir}/xcb'
AC_SUBST(xcbincludedir)