summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-20 02:33:25 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-25 19:22:52 +0200
commit05a203af120016428eb1661ee060ea85e37b4c96 (patch)
treedbbf9bf3903895a5b7f06eb22db6308627376a23 /Makefile.am
parent6db275a422013a34247b805923f88b23db850ea1 (diff)
build-sys: move codegen & proto to spice-common
With this iteration, all the spice_codegen.py/proto/marshaller generation has been moved to spice-common. The spice-common directory will ship spice-protocol, since it's needed there too to build libspice-common. Again, make distcheck passes. Build with mingw & fedora linux.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 24 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f1353c..0d168a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,8 @@
ACLOCAL_AMFLAGS = -I m4
NULL =
-SUBDIRS = spice-protocol common gtk po python_modules doc data
+SUBDIRS = spice-common gtk po doc data
+
if HAVE_INTROSPECTION
if WITH_VALA
SUBDIRS += vapi
@@ -12,30 +13,31 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = \
spice-client-glib-2.0.pc \
spice-client-gtk-$(SPICE_GTK_API_VERSION).pc \
- spice-controller.pc
+ spice-controller.pc \
+ $(NULL)
-INTLTOOL_FILES = intltool-extract.in \
- intltool-merge.in \
- intltool-update.in \
- $(NULL)
+INTLTOOL_FILES = \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in \
+ $(NULL)
-DISTCLEANFILES = $(pkgconfig_DATA) \
- intltool-extract \
- intltool-merge \
- intltool-update \
- gnome-doc-utils.make \
- po/.intltool-merge-cache \
- $(NULL)
+DISTCLEANFILES = \
+ $(pkgconfig_DATA) \
+ intltool-extract \
+ intltool-merge \
+ intltool-update \
+ gnome-doc-utils.make \
+ po/.intltool-merge-cache \
+ $(NULL)
-EXTRA_DIST = spice.proto \
- spice1.proto \
- spice_codegen.py \
- build-aux/git-version-gen \
- gtk-doc.make \
- .version \
- THANKS \
- $(INTLTOOL_FILES) \
- $(NULL)
+EXTRA_DIST = \
+ build-aux/git-version-gen \
+ gtk-doc.make \
+ .version \
+ THANKS \
+ $(INTLTOOL_FILES) \
+ $(NULL)
MAINTAINERCLEANFILES = \
ABOUT-NLS \
@@ -104,4 +106,3 @@ spicy-for-windows.exe:
/usr/i686-pc-mingw32/sys-root/mingw/lib/gstreamer-0.10/libgstcoreelements.dll
-include $(top_srcdir)/git.mk
-