summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2017-09-07 17:43:16 +0200
committerAdam Jackson <ajax@redhat.com>2018-01-24 11:34:59 -0500
commitda8de2a7f6ab52ef52039b0dc9978260232a34a6 (patch)
tree340c5878c6a43a077e5518cdda664355fb33001c /meson.build
parent75408f53d4e203e462b2f13ea4b06264f0e59ad2 (diff)
xwayland: Add optional xdg-output support
The xdg-output protocol aims at describing outputs in way which is more in line with the concept of an output on desktop oriented systems. For now it just features the position and logical size which describe the output position and size in the global compositor space. This is however much useful for Xwayland to advertise the output size and position to X11 clients which need this to configure their surfaces in the global compositor space as the compositor may apply a different scale from what is advertised by the output scaling property (to achieve fractional scaling, for example). This was added in wayland-protocols 1.10. Reviewed-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c028cc8aa..c9d9f27e1 100644
--- a/meson.build
+++ b/meson.build
@@ -147,7 +147,7 @@ if (host_machine.system() != 'darwin' and
xwayland_dep = [
dependency('wayland-client', version: '>= 1.3.0', required: xwayland_required),
- dependency('wayland-protocols', version: '>= 1.9', required: xwayland_required),
+ dependency('wayland-protocols', version: '>= 1.10', required: xwayland_required),
dependency('libdrm', version: '>= 2.3.1', required: xwayland_required),
dependency('epoxy', required: xwayland_required),
]